Please or Register to create posts and topics.

very unusual scarring (Craftbot Plus)

I am new here in this forum and hope to have understood all the rules. My search did not find a solution to our problem.

Our Craftbot Plus (which is now a few years old) has an unusual bug pattern in the form of grouped scars. We show it with the photos attached. All repeated attempts to fix the problem failed. With constant settings, the result is sometimes slightly better and sometimes much worse.

It is NOT caused by:

  • Temperature (hotend, bed & environment)
  • Flow rate (extensive series of tests carried out)
  • Z-seam position
  • Leveling (precisely adjusted and checked several times)
  • Print bed (flat, plane, temperature, good adhesion)
  • Belt tension
  • Material (the print with the used material works with other printers | the error occurs on the Craftbot with different materials)
  • Extruder gear (grooves free, firmly locked)
  • Nozzle (replaced and cleaned several times)
  • Hot End (thoroughly cleaned)
  • Slicer settings (also sliced with other programmes)
  • Firmware (updated and tried with various old firmware)


Is it possible that the stepper motor driver is broken and skips steps from time to time? We could not locate a driver. Is it possible to change it?

Do you think an alternative new unit consisting of direct extruder and hotend would help?

Is there anything we missed? Do you have any other suggestions?

Thanks a lot!

Uploaded files:
  • You need to login to have access to uploads.

Dear Ruben,

It looks like serious underextrusion on that parts. If the GCodes are correct (and we can assume that because you tried different slicers), less than the required amount of filament leaves the nozzle.

The most likely cause for that is the filament feeder cannot give the necessary torque to do that.

a, The torque is unexpectedly high:

  • Too high viscosity of the molten filament or not melted enough: not proper filament, or low temperature
  • Obstructed filament path: partial or full clog, or stuck filament

You rule out all of them

b, The given torque by the extruder is unexpectedly low:

  • There is no traction/grip and the filament slips: messy extruder gear, or not enough pressure on the filament
  • Weak/faulty stepper motor: various electrical and mechanical problems.

You rule out all of them too 🙂

My tips to investigate the case further:

1: when you extrude from the HMI, can you here clicking noises? that means the stepper skip steps. Or do you hear it when the underextruded pattern printed?

2: soft filament slip test:

From the top of the extruder measure x cm filament, and mark it there (x ~= 30-50 cm)

Run a simple gcode that only heats up and extrudes that x cm filament with a relatively high extrusion rate: 1-3 mm/s

if the mark is way off (more than 10-20% ) than there is not enough grip on the filament. Please tune the extruder gear!

Best Regards,










Hello András,

I'm sorry that I'm only getting back to you now. The question was moved and I didn't receive a notification about your answer, contrary to the settings. In any case, thank you very much for your support and your detailed answer!

Regarding your specific suggestions:

1. i absolutely cannot hear any clicking sounds when extruding.

2. i did the test to extrude 30cm five times. There was between 12mm and 17mm under-extruded each time. So it is a very slight under extrusion of about 5%.

The crazy thing about the error is that it sometimes only becomes visible after up to three hours of printing. With other objects, however, it is immediately visible. It seems to start at certain points in the geometry, independent of the slicer, and somehow builds up. These can be edges, curves or overhangs above openings. To avoid rocking up behind edges, the printer is now on the floor.

With best regards